What’s Vulnerable › Vulnerabilities
CVE-2022-2720
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-12 · updated 2026-06-17
- Weakness: CWE-359
Description
In affected versions of Octopus Server it was identified that when a sensitive value is a substring of another value, sensitive value masking will only partially work.
Affected products
- Octopus Deploy Octopus Server: from 3.16.4 before 2022.1.3154; from 2022.2.6729 before 2022.2.7934; from 2022.3.348 before 2022.3.10586 — fixed in 2022.1.3154, 2022.2.7934, 2022.3.10586
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.1.3154, 2022.2.7934, 2022.3.10586. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-18/
- https://advisories.octopus.com/post/2022/sa2022-18/
Get alerted when CVE-2022-2720 or the next vulnerability affects your stack