What’s Vulnerable › Vulnerabilities
CVE-2022-2721
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-25 · updated 2026-06-17
- Weakness: CWE-532
Description
In affected versions of Octopus Server it is possible for target discovery to print certain values marked as sensitive to log files in plaint-text in when verbose logging is enabled.
Affected products
- Octopus Deploy Octopus Server: from 2022.2.6729 before 2022.2.7965; from 2022.3.348 before 2022.3.9163 — fixed in 2022.2.7965, 2022.3.9163
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.2.7965, 2022.3.9163. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-24/
- https://advisories.octopus.com/post/2022/sa2022-24/
Get alerted when CVE-2022-2721 or the next vulnerability affects your stack