What’s Vulnerable › Vulnerabilities

CVE-2022-27223

Description

In drivers/usb/gadget/udc/udc-xilinx.c in the Linux kernel before 5.16.12, the endpoint index is not validated and might be manipulated by the host for out-of-array access.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.269, 4.19.232, 4.9.304, 5.10.103. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-27223 or the next vulnerability affects your stack