What’s Vulnerable › Vulnerabilities

CVE-2022-27227

Description

In PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and PowerDNS Recursor before 4.4.8, 4.5.x before 4.5.8, and 4.6.x before 4.6.1, insufficient validation of an IXFR end condition causes incomplete zone transfers to be handled as successful transfers.

Affected products

How to fix

Upgrade to a fixed version: PowerDNS Authoritative Server 4.4.3, 4.5.4, 4.6.1; PowerDNS Recursor 4.4.8, 4.5.8, 4.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-27227 or the next vulnerability affects your stack