What’s Vulnerable › Vulnerabilities
CVE-2022-27239
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-27 · updated 2026-06-17
- Weakness: CWE-787
Description
In cifs-utils through 6.14, a stack-based buffer overflow when parsing the mount.cifs ip= command-line argument could lead to local attackers gaining root privileges.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 34, 35, 36
- HP Helion Openstack: 8.0
- samba cifs-utils: before 6.15 — fixed in 6.15
- SUSE CaaS Platform 4.5: 4.0
- SUSE Enterprise Storage: 6.0, 7.0
- SUSE Linux Enterprise Server 15 SP1: 15-sp3, 15-sp4
- SUSE Linux Enterprise High Performance Computing: 12.0-sp5, 15.0, 15.0-sp1, 15.0-sp2, 15.0-sp3, 15.0-sp4
- SUSE Linux Enterprise Micro: 5.2
- SUSE Linux Enterprise Point Of Service: 11.0-sp3
- SUSE Linux Enterprise Real Time: 15.0-sp2
- SUSE Linux Enterprise Server: 11-sp3, 11-sp4, 12-sp2, 12-sp3, 12-sp4, 12-sp5 (+5)
- SUSE Linux Enterprise Software Development Kit: 12-sp5
- SUSE Linux Enterprise Storage: 7.1
- SUSE Manager Proxy: 4.1, 4.2, 4.3
- SUSE Manager Retail Branch Server: 4.1, 4.2, 4.3
- SUSE Manager Server: 4.1, 4.2, 4.3
- SUSE Openstack Cloud: 8.0, 9.0
- SUSE Openstack Cloud Crowbar: 8.0, 9.0
How to fix
Upgrade to a fixed version: samba cifs-utils 6.15. Check the vendor advisory for mitigations.
References
- http://wiki.robotz.com/index.php/Linux_CIFS_Utils_and_Samba
- https://bugzilla.samba.org/show_bug.cgi?id=15025
- https://bugzilla.suse.com/show_bug.cgi?id=1197216
- https://github.com/piastry/cifs-utils/pull/7
- https://github.com/piastry/cifs-utils/pull/7/commits/955fb147e97a6a74e1aaa65766de91e2c1479765
- https://lists.debian.org/debian-lts-announce/2022/05/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5WBOLMANBYJILXQKRRK7OCR774PXJAYY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HXKZLJYJJEC3TIBFLXUORRMZUKG5W676/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QIYZ4L6SLSYJQ446VJAO2VGAESURQNSP/
- https://security.gentoo.org/glsa/202311-05
- https://www.debian.org/security/2022/dsa-5157
- http://wiki.robotz.com/index.php/Linux_CIFS_Utils_and_Samba
Get alerted when CVE-2022-27239 or the next vulnerability affects your stack