What’s Vulnerable › Vulnerabilities
CVE-2022-27240
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-18 · updated 2026-06-17
- Weakness: CWE-120
Description
scheme/webauthn.c in Glewlwyd SSO server 2.x before 2.6.2 has a buffer overflow associated with a webauthn assertion.
Affected products
- Glewlwyd Sso Server Project Glewlwyd Sso Server: from 2.0.0 before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: Glewlwyd Sso Server Project Glewlwyd Sso Server 2.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/babelouest/glewlwyd/commit/4c5597c155bfbaf6491cf6b83479d241ae66940a
- https://github.com/babelouest/glewlwyd/releases/tag/v2.6.2
- https://github.com/babelouest/glewlwyd/commit/4c5597c155bfbaf6491cf6b83479d241ae66940a
- https://github.com/babelouest/glewlwyd/releases/tag/v2.6.2
Get alerted when CVE-2022-27240 or the next vulnerability affects your stack