What’s Vulnerable › Vulnerabilities
CVE-2022-27377
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-12 · updated 2026-06-17
- Weakness: CWE-416
Description
MariaDB Server v10.6.3 and below was discovered to contain an use-after-free in the component Item_func_in::cleanup(), which is exploited via specially crafted SQL statements.
Affected products
- Debian Linux: 10.0
- MariaDB: from 10.2.0 before 10.2.44; from 10.3.0 before 10.3.35; from 10.4.0 before 10.4.25; from 10.5.0 before 10.5.16; from 10.6.0 before 10.6.8; from 10.7.0 before 10.7.4 — fixed in 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4
How to fix
Upgrade to a fixed version: MariaDB 10.2.44, 10.3.35, 10.4.25, 10.5.16. Check the vendor advisory for mitigations.
References
- https://jira.mariadb.org/browse/MDEV-26281
- https://lists.debian.org/debian-lts-announce/2022/09/msg00023.html
- https://security.netapp.com/advisory/ntap-20220526-0007/
- https://jira.mariadb.org/browse/MDEV-26281
- https://lists.debian.org/debian-lts-announce/2022/09/msg00023.html
- https://security.netapp.com/advisory/ntap-20220526-0007/
Get alerted when CVE-2022-27377 or the next vulnerability affects your stack