What’s Vulnerable › Vulnerabilities
CVE-2022-27438
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-06 · updated 2026-07-09
- Weakness: CWE-494
Description
Caphyon Ltd Advanced Installer 19.3 and earlier and many products that use the updater from Advanced Installer (Advanced Updater) are affected by a remote code execution vulnerability via the CustomDetection parameter in the update check function. To exploit this vulnerability, a user must start an affected installation to trigger the update check.
Affected products
- 3CX Call Flow Designer: 18.2.13
- 3CX Crm Template Generator: 2.1.23
- Boomtv Streamer Portal: 2.2.1
- Caphyon Advanced Installer: before 19.4 — fixed in 19.4
- Codesector Direct Folders: 4.0
- Codesector Teracopy: 3.8.5
- Emeditor: 21.3.0
- Flamory: 4.2.19.0
- Freesnippingtool Free Snipping Tool: 5.6.0.0
- Fxsound: 1.1.12.0
- Gainedge Better Explorer: 2020.3.15.1304
- Gamecaster: 4.0.2109.2802
- Getmailbird Mailbird: 2.9.50.0
- Guzogo: 1.0.5.0
- Honeygain: 0.10.7.0
- Jki Vi Package Manager: 21.1.2754
- Jpsoft Take Command: 28.2.18
- Krylack Archive Password Recovery: 3.70.69
- Krylack Asterisks Password Decryptor: 3.31.107
- Krylack Burning Suite: 1.20.05
- Krylack Rar Password Recovery: 3.70.69
- Krylack Volume Serial Number Editor: 2.02.34
- Krylack Zip Password Recovery: 3.70.69
- Moonsoftware Password Agent: 20.10.1
- Nefarius Scptoolkit: 1.6.238.16010
- Plagiarismcheckerx Plagiarism Checker X: 8.0.6
- Prusa3D Prusaslicer: 2.4.2
- RealDefense Mycleanid: 4.1.4
- RealDefense Mycleanpc: 4.0.2
- RealDefense Mypasslock: 1.9.6
How to fix
Upgrade to a fixed version: Caphyon Advanced Installer 19.4. Check the vendor advisory for mitigations.
References
- https://gerr.re/posts/cve-2022-27438/
- https://www.advancedinstaller.com/security-updates-auto-updater.html
- https://gerr.re/posts/cve-2022-27438/
- https://www.advancedinstaller.com/security-updates-auto-updater.html
Get alerted when CVE-2022-27438 or the next vulnerability affects your stack