What’s Vulnerable › Vulnerabilities
CVE-2022-27445
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-14 · updated 2026-06-17
Description
MariaDB Server v10.9 and below was discovered to contain a segmentation fault via the component sql/sql_window.cc.
Affected products
- Debian Linux: 10.0
- MariaDB: from 10.2.0 before 10.2.44; from 10.3.0 before 10.3.35; from 10.4.0 before 10.4.25; from 10.5.0 before 10.5.16; from 10.6.0 before 10.6.8; from 10.7.0 before 10.7.4 — fixed in 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4
How to fix
Upgrade to a fixed version: MariaDB 10.2.44, 10.3.35, 10.4.25, 10.5.16. Check the vendor advisory for mitigations.
References
- https://jira.mariadb.org/browse/MDEV-28081
- https://lists.debian.org/debian-lts-announce/2022/09/msg00023.html
- https://security.netapp.com/advisory/ntap-20220526-0006/
- https://jira.mariadb.org/browse/MDEV-28081
- https://lists.debian.org/debian-lts-announce/2022/09/msg00023.html
- https://security.netapp.com/advisory/ntap-20220526-0006/
Get alerted when CVE-2022-27445 or the next vulnerability affects your stack