What’s Vulnerable › Vulnerabilities

CVE-2022-27447

Description

MariaDB Server v10.9 and below was discovered to contain a use-after-free via the component Binary_string::free_buffer() at /sql/sql_string.h.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.3.35, 10.4.25, 10.5.16, 10.6.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-27447 or the next vulnerability affects your stack