What’s Vulnerable › Vulnerabilities
CVE-2022-27479: SQL injection vulnerability in chart data API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-13 · updated 2026-06-17
- Weakness: CWE-89
Description
Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests. Users should update to 1.4.2 or higher which addresses this issue.
Affected products
- Apache Superset: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: Apache Superset 1.4.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/04/13/3
- https://lists.apache.org/thread/94th50j5d0y2fw7ysx0g7w3t6jk3z7q6
- https://lists.apache.org/thread/ztb9b6jd9rngoxwvq8r4fhpp401o613y
- http://www.openwall.com/lists/oss-security/2022/04/13/3
- https://lists.apache.org/thread/94th50j5d0y2fw7ysx0g7w3t6jk3z7q6
- https://lists.apache.org/thread/ztb9b6jd9rngoxwvq8r4fhpp401o613y
Get alerted when CVE-2022-27479 or the next vulnerability affects your stack