What’s Vulnerable › Vulnerabilities
CVE-2022-27482
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-78
Description
A improper neutralization of special elements used in an os command ('os command injection') in Fortinet FortiADC version 7.0.0 through 7.0.1, 6.2.0 through 6.2.2, 6.1.0 through 6.1.6, 6.0.x, 5.x.x allows attacker to execute arbitrary shell code as `root` via CLI commands.
Affected products
- Fortinet FortiADC: from 5.0.0 through 5.0.4; from 5.1.0 through 5.1.7; from 5.2.0 through 5.2.8; from 5.3.0 through 5.3.7; from 5.4.0 through 5.4.5; from 6.0.0 through 6.0.4 — fixed in 6.2.4
How to fix
Upgrade to a fixed version: Fortinet FortiADC 6.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-27482 or the next vulnerability affects your stack