What’s Vulnerable › Vulnerabilities
CVE-2022-27536
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-20 · updated 2026-06-17
- Weakness: CWE-295
Description
Certificate.Verify in crypto/x509 in Go 1.18.x before 1.18.1 can be caused to panic on macOS when presented with certain malformed certificates. This allows a remote TLS server to cause a TLS client to panic.
Affected products
- Go: from 1.18.0 before 1.18.1 — fixed in 1.18.1
How to fix
Upgrade to a fixed version: Go 1.18.1. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-744259.pdf
- https://groups.google.com/g/golang-announce
- https://groups.google.com/g/golang-announce/c/oecdBNLOml8
- https://security.gentoo.org/glsa/202208-02
- https://security.netapp.com/advisory/ntap-20230309-0001/
- https://cert-portal.siemens.com/productcert/pdf/ssa-744259.pdf
- https://groups.google.com/g/golang-announce
- https://groups.google.com/g/golang-announce/c/oecdBNLOml8
- https://security.gentoo.org/glsa/202208-02
- https://security.netapp.com/advisory/ntap-20230309-0001/
Get alerted when CVE-2022-27536 or the next vulnerability affects your stack