What’s Vulnerable › Vulnerabilities
CVE-2022-27595: QVPN Device Client
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-427
Description
An insecure library loading vulnerability has been reported to affect QVPN Device Client. If exploited, the vulnerability could allow local attackers who have gained user access to execute unauthorized code or commands. We have already fixed the vulnerability in the following versions: QVPN Windows 2.0.0.1316 and later QVPN Windows 2.0.0.1310 and later
Affected products
- QNAP Systems Inc. QVPN Windows: before 2.0.0.1316 — fixed in 2.0.0.1316
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QVPN Windows 2.0.0.1316. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-27595 or the next vulnerability affects your stack