What’s Vulnerable › Vulnerabilities
CVE-2022-27596: Vulnerability in QTS
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability has been reported to affect QNAP device running QuTS hero, QTS. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions of QuTS hero, QTS: QuTS hero h5.0.1.2248 build 20221215 and later QTS 5.0.1.2234 build 20221201 and later
Affected products
- QNAP QTS: from 5.0.1 before 5.0.1.2234 — fixed in 5.0.1.2234
- QNAP Systems Inc. QuTS hero: from h5.0.1 before h5.0.1.2248 — fixed in h5.0.1.2248
How to fix
Upgrade to a fixed version: QNAP QTS 5.0.1.2234; QNAP Systems Inc. QuTS hero h5.0.1.2248. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-23-01
- https://www.qnap.com/en/security-advisory/qsa-23-01
Get alerted when CVE-2022-27596 or the next vulnerability affects your stack