What’s Vulnerable › Vulnerabilities
CVE-2022-27598: QTS, QuTS hero, QuTScloud, QVP (QVR Pro appliances)
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-125
Description
A vulnerability has been reported to affect QNAP operating systems. If exploited, the out-of-bounds read vulnerability allows remote authenticated administrators to get secret values. The vulnerability affects the following QNAP operating systems: QTS, QuTS hero, QuTScloud, QVP (QVR Pro appliances) We have already fixed the vulnerability in the following versions: QTS 5.0.1.2346 build 20230322 and later QuTS hero h5.0.1.2348 build 20230324 and later
Affected products
- QNAP QTS: before 5.0.1.2346 — fixed in 5.0.1.2346
- QNAP Systems Inc. QuTS hero: before h5.0.1.2348 — fixed in h5.0.1.2348
- QNAP Systems Inc. QuTScloud: all versions
- QNAP Qvp-21A Firmware: all versions
- QNAP Qvp-41A Firmware: all versions
- QNAP Qvp-41B Firmware: all versions
- QNAP Qvp-63A Firmware: all versions
- QNAP Qvp-63B Firmware: all versions
- QNAP Qvp-85A Firmware: all versions
- QNAP Qvp-85B Firmware: all versions
How to fix
Upgrade to a fixed version: QNAP QTS 5.0.1.2346; QNAP Systems Inc. QuTS hero h5.0.1.2348. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-23-06
- https://www.qnap.com/en/security-advisory/qsa-23-06
Get alerted when CVE-2022-27598 or the next vulnerability affects your stack