What’s Vulnerable › Vulnerabilities
CVE-2022-2760
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-28 · updated 2026-06-17
- Weakness: CWE-209
Description
In affected versions of Octopus Deploy it is possible to reveal the Space ID of spaces that the user does not have access to view in an error message when a resource is part of another Space.
Affected products
- Octopus Deploy Octopus Server: from 2019.5.7 before 2022.1.3180; from 2022.2.0 before 2022.2.7965; from 2022.3.0 before 2022.3.10405 — fixed in 2022.1.3180, 2022.2.7965, 2022.3.10405
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.1.3180, 2022.2.7965, 2022.3.10405. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-14/
- https://advisories.octopus.com/post/2022/sa2022-14/
Get alerted when CVE-2022-2760 or the next vulnerability affects your stack