What’s Vulnerable › Vulnerabilities
CVE-2022-27600: QTS, QuTS hero, QuTScloud
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-400
Description
An uncontrolled resource consumption vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow remote attackers to launch a denial-of-service (DoS) attack. We have already fixed the vulnerability in the following versions: QTS 5.0.1.2277 and later QTS 4.5.4.2280 build 20230112 and later QuTS hero h5.0.1.2277 build 20230112 and later QuTS hero h4.5.4.2374 build 20230417 and later QuTScloud c5.0.1.2374 and later
Affected products
- QNAP QTS: from 4.5.1 before 4.5.4.2280; from 5.0.0 before 5.0.1.2277; 4.5.4.2280, 5.0.1.2277 — fixed in 4.5.4.2280, 5.0.1.2277
- QNAP Systems Inc. QuTS hero: from h4.5.1 before h4.5.4.2374; from h5.0 before h5.0.1.2277; h4.5.4.2374, h5.0.1.2277 — fixed in h4.5.4.2374, h5.0.1.2277
- QNAP Systems Inc. QuTScloud: from c5.0.1 before c5.0.1.2374 — fixed in c5.0.1.2374
How to fix
Upgrade to a fixed version: QNAP QTS 4.5.4.2280, 5.0.1.2277; QNAP Systems Inc. QuTS hero h4.5.4.2374, h5.0.1.2277; QNAP Systems Inc. QuTScloud c5.0.1.2374. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-27600 or the next vulnerability affects your stack