What’s Vulnerable › Vulnerabilities
CVE-2022-27610
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-27 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper limitation of a pathname to a restricted directory ('Path Traversal') vulnerability in webapi component in Synology DiskStation Manager (DSM) before 6.2.3-25423 allows remote authenticated users to delete arbitrary files via unspecified vectors.
Affected products
- Synology DiskStation Manager: from 6.2 before 6.2.3-25423 — fixed in 6.2.3-25423
How to fix
Upgrade to a fixed version: Synology DiskStation Manager 6.2.3-25423. Check the vendor advisory for mitigations.
References
- https://www.synology.com/security/advisory/Synology_SA_20_06
- https://www.synology.com/security/advisory/Synology_SA_20_06
Get alerted when CVE-2022-27610 or the next vulnerability affects your stack