What’s Vulnerable › Vulnerabilities
CVE-2022-27616
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-03 · updated 2026-06-17
- Weakness: CWE-78
Description
Improper neutralization of special elements used in an OS command ('OS Command Injection') vulnerability in webapi component in Synology DiskStation Manager (DSM) before 7.0.1-42218-3 allows remote authenticated users to execute arbitrary commands via unspecified vectors.
Affected products
- Synology DiskStation Manager: from 6.2 before 6.2.4-25556-5; from 7.0 before 7.0.1-42218-3 — fixed in 6.2.4-25556-5, 7.0.1-42218-3
How to fix
Upgrade to a fixed version: Synology DiskStation Manager 6.2.4-25556-5, 7.0.1-42218-3. Check the vendor advisory for mitigations.
References
- https://www.synology.com/security/advisory/Synology_SA_22_03
- https://www.synology.com/security/advisory/Synology_SA_22_03
Get alerted when CVE-2022-27616 or the next vulnerability affects your stack