What’s Vulnerable › Vulnerabilities
CVE-2022-27618
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-03 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper limitation of a pathname to a restricted directory ('Path Traversal') vulnerability in webapi component in Synology Storage Analyzer before 2.1.0-0390 allows remote authenticated users to delete arbitrary files via unspecified vectors.
Affected products
- Synology Storage Analyzer: before 2.1.0-0390; before 2.0.1-0214 — fixed in 2.0.1-0214, 2.1.0-0390
How to fix
Upgrade to a fixed version: Synology Storage Analyzer 2.0.1-0214, 2.1.0-0390. Check the vendor advisory for mitigations.
References
- https://www.synology.com/security/advisory/Synology_SA_22_11
- https://www.synology.com/security/advisory/Synology_SA_22_11
Get alerted when CVE-2022-27618 or the next vulnerability affects your stack