What’s Vulnerable › Vulnerabilities
CVE-2022-27624
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-20 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability regarding improper restriction of operations within the bounds of a memory buffer is found in the packet decryption functionality of Out-of-Band (OOB) Management. This allows remote attackers to execute arbitrary commands via unspecified vectors. The following models with Synology DiskStation Manager (DSM) versions before 7.1.1-42962-2 may be affected: DS3622xs+, FS3410, and HD6500.
Affected products
- Synology DiskStation Manager: before 7.1.1-42962-2 — fixed in 7.1.1-42962-2
How to fix
Upgrade to a fixed version: Synology DiskStation Manager 7.1.1-42962-2. Check the vendor advisory for mitigations.
References
- https://www.synology.com/security/advisory/Synology_SA_22_17
- https://www.synology.com/security/advisory/Synology_SA_22_17
Get alerted when CVE-2022-27624 or the next vulnerability affects your stack