What’s Vulnerable › Vulnerabilities
CVE-2022-27641
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-190
Description
This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6700v3 1.0.4.120_10.0.91 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the NetUSB module. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-15806.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.68 — fixed in 1.0.1.68
- Netgear EX6200: before 1.0.1.90 — fixed in 1.0.1.90
- NETGEAR Ex8000 Firmware: before 1.0.1.240 — fixed in 1.0.1.240
- NETGEAR R6220 Firmware: before 1.1.0.112 — fixed in 1.1.0.112
- NETGEAR R6230 Firmware: before 1.1.0.112 — fixed in 1.1.0.112
- NETGEAR R6400 Firmware: before 1.0.4.122 — fixed in 1.0.4.122
- NETGEAR R6700: before 1.0.4.122 — fixed in 1.0.4.122
- NETGEAR R7000: before 1.0.11.130 — fixed in 1.0.11.130
- NETGEAR R7800 Firmware: before 1.0.2.90 — fixed in 1.0.2.90
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.68; Netgear EX6200 1.0.1.90; NETGEAR Ex8000 Firmware 1.0.1.240; NETGEAR R6220 Firmware 1.1.0.112; NETGEAR R6230 Firmware 1.1.0.112; NETGEAR R6400 Firmware 1.0.4.122; NETGEAR R6700 1.0.4.122; NETGEAR R7000 1.0.11.130; NETGEAR R7800 Firmware 1.0.2.90. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064437/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Multiple-Products-PSV-2021-0278
- https://www.zerodayinitiative.com/advisories/ZDI-22-544/
- https://kb.netgear.com/000064437/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Multiple-Products-PSV-2021-0278
- https://www.zerodayinitiative.com/advisories/ZDI-22-544/
Get alerted when CVE-2022-27641 or the next vulnerability affects your stack