What’s Vulnerable › Vulnerabilities
CVE-2022-27643
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 25.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-120
Description
This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6700v3 1.0.4.120_10.0.91 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of SOAP requests. When parsing the SOAPAction header, the process does not properly validate the length of user-supplied data prior to copying it to a buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-15692.
Affected products
- NETGEAR D6220 Firmware: before 1.0.0.80 — fixed in 1.0.0.80
- Netgear D6400: before 1.0.0.114 — fixed in 1.0.0.114
- NETGEAR D7000V2 Firmware: before 1.0.0.80 — fixed in 1.0.0.80
- NETGEAR Dc112A Firmware: before 1.0.0.64 — fixed in 1.0.0.64
- NETGEAR EX3700: before 1.0.0.96 — fixed in 1.0.0.96
- NETGEAR Ex3800 Firmware: before 1.0.0.96 — fixed in 1.0.0.96
- NETGEAR EX6120: before 1.0.0.68 — fixed in 1.0.0.68
- NETGEAR Ex6130 Firmware: before 1.0.0.48 — fixed in 1.0.0.48
- NETGEAR R6400 Firmware: before 1.0.1.78; before 1.0.4.126 — fixed in 1.0.1.78, 1.0.4.126
- NETGEAR R6700: before 1.0.4.126 — fixed in 1.0.4.126
- NETGEAR R6900P Firmware: before 1.3.3.148 — fixed in 1.3.3.148
- NETGEAR R7000: before 1.0.11.134 — fixed in 1.0.11.134
- NETGEAR R7000P: before 1.3.3.148 — fixed in 1.3.3.148
- NETGEAR R7100Lg Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR R7850 Firmware: before 1.0.5.84 — fixed in 1.0.5.84
- NETGEAR R7900P Firmware: before 1.4.3.88 — fixed in 1.4.3.88
- NETGEAR R7960P Firmware: before 1.4.3.88 — fixed in 1.4.3.88
- NETGEAR R8000 Firmware: before 1.0.4.84 — fixed in 1.0.4.84
- NETGEAR R8000P Firmware: before 1.4.3.88 — fixed in 1.4.3.88
- NETGEAR R8500 Firmware: before 1.0.2.158 — fixed in 1.0.2.158
- NETGEAR Rax200 Firmware: before 1.0.6.138 — fixed in 1.0.6.138
- NETGEAR Rax75 Firmware: before 1.0.6.138 — fixed in 1.0.6.138
- NETGEAR Rax80 Firmware: before 1.0.6.138 — fixed in 1.0.6.138
- NETGEAR Rs400 Firmware: before 1.5.1.86 — fixed in 1.5.1.86
- NETGEAR Wndr3400 Firmware: before 1.0.1.44 — fixed in 1.0.1.44
- NETGEAR Wnr3500L Firmware: before 1.2.0.72 — fixed in 1.2.0.72
- NETGEAR Xr300 Firmware: before 1.0.3.72 — fixed in 1.0.3.72
How to fix
Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.80; Netgear D6400 1.0.0.114; NETGEAR D7000V2 Firmware 1.0.0.80; NETGEAR Dc112A Firmware 1.0.0.64; NETGEAR EX3700 1.0.0.96; NETGEAR Ex3800 Firmware 1.0.0.96; NETGEAR EX6120 1.0.0.68; NETGEAR Ex6130 Firmware 1.0.0.48; NETGEAR R6400 Firmware 1.0.1.78, 1.0.4.126; NETGEAR R6700 1.0.4.126; NETGEAR R6900P Firmware 1.3.3.148; NETGEAR R7000 1.0.11.134. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064720/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Multiple-Products-PSV-2021-0323
- https://www.zerodayinitiative.com/advisories/ZDI-22-519/
- https://kb.netgear.com/000064720/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Multiple-Products-PSV-2021-0323
- https://www.zerodayinitiative.com/advisories/ZDI-22-519/
Get alerted when CVE-2022-27643 or the next vulnerability affects your stack