What’s Vulnerable › Vulnerabilities
CVE-2022-2777: Cross-site Scripting (XSS) - Stored in microweber/microweber
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.3.1.
Affected products
- microweber/microweber: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: microweber/microweber 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/60eef7494211d1c458228c321e986edeaa401a58
- https://huntr.dev/bounties/13dd2f4d-0c7f-483e-a771-e1ed2ff1c36f
- https://github.com/microweber/microweber/commit/60eef7494211d1c458228c321e986edeaa401a58
- https://huntr.dev/bounties/13dd2f4d-0c7f-483e-a771-e1ed2ff1c36f
Get alerted when CVE-2022-2777 or the next vulnerability affects your stack