What’s Vulnerable › Vulnerabilities
CVE-2022-27777: XSS Vulnerability in Action View tag helpers
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-26 · updated 2026-06-17
- Weakness: CWE-79
Description
A XSS Vulnerability in Action View tag helpers >= 5.2.0 and < 5.2.0 which would allow an attacker to inject content if able to control input into specific attributes.
Affected products
- Debian Linux: 10.0
- rails actionpack: before 5.2.7.1; from 6.0.0 before 6.0.4.8; from 6.1.0 before 6.1.5.1; from 7.0.0 before 7.0.2.4 — fixed in 5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4
- Rubygems Actionview: before 5.2.7.1; from 6.0.0 before 6.0.4.8; from 6.1.0 before 6.1.5.1; from 7.0.0 before 7.0.2.4; 4.1.0, 4.1.0.beta1, 4.1.0.beta2, 4.1.0.rc1, 4.1.0.rc2, 4.1.1 (+193) — fixed in 5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4
How to fix
Upgrade to a fixed version: rails actionpack 5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4; Rubygems Actionview 5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4. Check the vendor advisory for mitigations.
References
- https://discuss.rubyonrails.org/t/cve-2022-27777-possible-xss-vulnerability-in-action-view-tag-helpers/80534
- https://lists.debian.org/debian-lts-announce/2022/09/msg00002.html
- https://www.debian.org/security/2023/dsa-5372
- https://discuss.rubyonrails.org/t/cve-2022-27777-possible-xss-vulnerability-in-action-view-tag-helpers/80534
- https://lists.debian.org/debian-lts-announce/2022/09/msg00002.html
- https://www.debian.org/security/2023/dsa-5372
Get alerted when CVE-2022-27777 or the next vulnerability affects your stack