What’s Vulnerable › Vulnerabilities
CVE-2022-2778
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-30 · updated 2026-06-17
Description
In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes.
Affected products
- Octopus Deploy Octopus Server: from 3.0 before 2022.2.8277; from 2022.3.348 before 2022.3.10405; from 2022.4.791 before 2022.4.1371 — fixed in 2022.2.8277, 2022.3.10405, 2022.4.1371
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.2.8277, 2022.3.10405, 2022.4.1371. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-15/
- https://advisories.octopus.com/post/2022/sa2022-15/
Get alerted when CVE-2022-2778 or the next vulnerability affects your stack