What’s Vulnerable › Vulnerabilities
CVE-2022-2780
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-14 · updated 2026-06-17
- Weakness: CWE-294
Description
In affected versions of Octopus Server it is possible to use the Git Connectivity test function on the VCS project to initiate an SMB request resulting in the potential for an NTLM relay attack.
Affected products
- Octopus Deploy Octopus Server: from 2021.2.994 before 2022.1.3180; from 2022.2.6729 before 2022.2.7965; from 2022.3.348 before 2022.3.10586 — fixed in 2022.1.3180, 2022.2.7965, 2022.3.10586
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.1.3180, 2022.2.7965, 2022.3.10586. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-20/
- https://advisories.octopus.com/post/2022/sa2022-20/
Get alerted when CVE-2022-2780 or the next vulnerability affects your stack