What’s Vulnerable › Vulnerabilities
CVE-2022-27811
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-24 · updated 2026-06-17
- Weakness: CWE-78
Description
GNOME OCRFeeder before 0.8.4 allows OS command injection via shell metacharacters in a PDF or image filename.
Affected products
- GNOME Ocrfeeder: before 0.8.4 — fixed in 0.8.4
How to fix
Upgrade to a fixed version: GNOME Ocrfeeder 0.8.4. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/ocrfeeder/-/commit/5286120c8bc8b7ba74e0f9b19b5262b509f38cee
- https://gitlab.gnome.org/GNOME/ocrfeeder/-/issues/20
- https://gitlab.gnome.org/GNOME/ocrfeeder/-/merge_requests/13
- https://gitlab.gnome.org/GNOME/ocrfeeder/-/commit/5286120c8bc8b7ba74e0f9b19b5262b509f38cee
- https://gitlab.gnome.org/GNOME/ocrfeeder/-/issues/20
- https://gitlab.gnome.org/GNOME/ocrfeeder/-/merge_requests/13
Get alerted when CVE-2022-27811 or the next vulnerability affects your stack