What’s Vulnerable › Vulnerabilities
CVE-2022-2782
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-27 · updated 2026-06-17
- Weakness: CWE-613
Description
In affected versions of Octopus Server it is possible for a session token to be valid indefinitely due to improper validation of the session token parameters.
Affected products
- Octopus Deploy Octopus Server: before 2022.2.8351; from 2022.3.0 before 2022.3.10586; from 2022.4.0 before 2022.4.2898 — fixed in 2022.2.8351, 2022.3.10586, 2022.4.2898
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.2.8351, 2022.3.10586, 2022.4.2898. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-21/
- https://advisories.octopus.com/post/2022/sa2022-21/
Get alerted when CVE-2022-2782 or the next vulnerability affects your stack