What’s Vulnerable › Vulnerabilities
CVE-2022-2783
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-06 · updated 2026-06-17
- Weakness: CWE-352
Description
In affected versions of Octopus Server it was identified that a session cookie could be used as the CSRF token
Affected products
- Octopus Deploy Octopus Server: from 3.12.0 before 2022.1.3154; from 2022.2.6729 before 2022.2.7897; from 2022.3.348 before 2022.3.10586 — fixed in 2022.1.3154, 2022.2.7897, 2022.3.10586
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.1.3154, 2022.2.7897, 2022.3.10586. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-17/
- https://advisories.octopus.com/post/2022/sa2022-17/
Get alerted when CVE-2022-2783 or the next vulnerability affects your stack