What’s Vulnerable › Vulnerabilities
CVE-2022-27891: Palantir Gotham included an unauthenticated endpoint that listed all active usernames in the platform with an active session.
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-200
Description
Palantir Gotham included an unauthenticated endpoint that listed all active usernames on the stack with an active session. The affected services have been patched and automatically deployed to all Apollo-managed Gotham instances. It is highly recommended that customers upgrade all affected services to the latest version. This issue affects: Palantir Gotham versions prior to 103.30221005.0.
Affected products
- Palantir Gotham: before 3.22.10.4 — fixed in 3.22.10.4
How to fix
Upgrade to a fixed version: Palantir Gotham 3.22.10.4. Check the vendor advisory for mitigations.
References
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-10.md
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-10.md
Get alerted when CVE-2022-27891 or the next vulnerability affects your stack