What’s Vulnerable › Vulnerabilities
CVE-2022-27893: The Foundry Magritte plugin osisoft-pi-web-connector was found to be logging in a manner that captured authentication requests.
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-04 · updated 2026-06-17
- Weakness: CWE-532
Description
The Foundry Magritte plugin osisoft-pi-web-connector versions 0.15.0 - 0.43.0 was found to be logging in a manner that captured authentication requests. This vulnerability is resolved in osisoft-pi-web-connector version 0.44.0.
Affected products
- Palantir Foundry Magritte plugin osisoft-pi-web-connector: from 0.15.0 before 0.44.0 — fixed in 0.44.0
How to fix
Upgrade to a fixed version: Palantir Foundry Magritte plugin osisoft-pi-web-connector 0.44.0. Check the vendor advisory for mitigations.
References
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-03.md
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-03.md
Get alerted when CVE-2022-27893 or the next vulnerability affects your stack