What’s Vulnerable › Vulnerabilities
CVE-2022-27894: The Foundry Blobster service was found to have a cross-site scripting (XSS) vulnerability.
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Foundry Blobster service was found to have a cross-site scripting (XSS) vulnerability that could have allowed an attacker with access to Foundry to launch attacks against other users. This vulnerability is resolved in Blobster 3.228.0.
Affected products
- Palantir Foundry Blobster Service: from 3.207.0 before 3.227.0 — fixed in 3.227.0
How to fix
Upgrade to a fixed version: Palantir Foundry Blobster Service 3.227.0. Check the vendor advisory for mitigations.
References
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-04.md
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-04.md
Get alerted when CVE-2022-27894 or the next vulnerability affects your stack