What’s Vulnerable › Vulnerabilities
CVE-2022-27896: The Foundry Code-Workbooks service was found to contain an issue leading to information disclosure.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-532
Description
Information Exposure Through Log Files vulnerability discovered in Foundry Code-Workbooks where the endpoint backing that console was generating service log records of any Python code being run. These service logs included the Foundry token that represents the Code-Workbooks Python console. Upgrade to Code-Workbooks version 4.461.0. This issue affects Palantir Foundry Code-Workbooks version 4.144 to version 4.460.0 and is resolved in 4.461.0.
Affected products
- Palantir Foundry Code-Workbooks: from 4.144.0 before 4.461.0 — fixed in 4.461.0
How to fix
Upgrade to a fixed version: Palantir Foundry Code-Workbooks 4.461.0. Check the vendor advisory for mitigations.
References
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-08.md
- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-08.md
Get alerted when CVE-2022-27896 or the next vulnerability affects your stack