What’s Vulnerable › Vulnerabilities
CVE-2022-27938
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-26 · updated 2026-06-17
- Weakness: CWE-617
Description
stb_image.h (aka the stb image loader) 2.19, as used in libsixel and other products, has a reachable assertion in stbi__create_png_image_raw.
Affected products
- Libsixel: before 1.10.4 — fixed in 1.10.4
- saitoha libsixel: before 1.8.7 — fixed in 1.8.7
How to fix
Upgrade to a fixed version: Libsixel 1.10.4; saitoha libsixel 1.8.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-27938 or the next vulnerability affects your stack