What’s Vulnerable › Vulnerabilities
CVE-2022-2796: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.4.
Affected products
- pimcore/pimcore: before 10.5.4 — fixed in 10.5.4
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/2fd46859c1def6b5ab79ae2b9cb88c309769443d
- https://huntr.dev/bounties/69d56ec3-8370-44cf-9732-4065e3076097
- https://github.com/pimcore/pimcore/commit/2fd46859c1def6b5ab79ae2b9cb88c309769443d
- https://huntr.dev/bounties/69d56ec3-8370-44cf-9732-4065e3076097
Get alerted when CVE-2022-2796 or the next vulnerability affects your stack