What’s Vulnerable › Vulnerabilities
CVE-2022-28054
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 31.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-02 · updated 2026-06-17
Description
Improper sanitization of trigger action scripts in VanDyke Software VShell for Windows v4.6.2 allows attackers to execute arbitrary code via a crafted value.
Affected products
- Vandyke Vshell: before 4.6.3 — fixed in 4.6.3
How to fix
Upgrade to a fixed version: Vandyke Vshell 4.6.3. Check the vendor advisory for mitigations.
References
- https://www.vandyke.com/support/advisory/2022/02/remote-execution-via-triggers.html
- https://www.vandyke.com/support/advisory/2022/02/remote-execution-via-triggers.html
Get alerted when CVE-2022-28054 or the next vulnerability affects your stack