What’s Vulnerable › Vulnerabilities
CVE-2022-28108
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-19 · updated 2026-06-17
- Weakness: CWE-352
Description
Selenium Server (Grid) before 4 allows CSRF because it permits non-JSON content types such as application/x-www-form-urlencoded, multipart/form-data, and text/plain.
Affected products
- Selenium Grid: before 4.0.0; 4.0.0, 4.0.0-alpha1, 4.0.0-alpha2, 4.0.0-alpha3, 4.0.0-alpha4, 4.0.0-alpha5 (+1) — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Selenium Grid 4.0.0. Check the vendor advisory for mitigations.
References
- https://www.gabriel.urdhr.fr/2022/02/07/selenium-standalone-server-csrf-dns-rebinding-rce/
- https://www.openwall.com/lists/oss-security/2022/02/07/3
- https://www.selenium.dev/downloads/
- https://www.gabriel.urdhr.fr/2022/02/07/selenium-standalone-server-csrf-dns-rebinding-rce/
- https://www.openwall.com/lists/oss-security/2022/02/07/3
- https://www.selenium.dev/downloads/
Get alerted when CVE-2022-28108 or the next vulnerability affects your stack