What’s Vulnerable › Vulnerabilities
CVE-2022-2816: Out-of-bounds Read in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-15 · updated 2026-06-17
- Weakness: CWE-125
Description
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.0212.
Affected products
- Fedoraproject Fedora: 35
- vim/vim: before 9.0.0212 — fixed in 9.0.0212
How to fix
Upgrade to a fixed version: vim/vim 9.0.0212. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/dbdd16b62560413abcc3c8e893cc3010ccf31666
- https://huntr.dev/bounties/e2a83037-fcf9-4218-b2b9-b7507dacde58
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CHFAR6OY6G77M6GXCJT75A4KITLNR6GO/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/dbdd16b62560413abcc3c8e893cc3010ccf31666
- https://huntr.dev/bounties/e2a83037-fcf9-4218-b2b9-b7507dacde58
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CHFAR6OY6G77M6GXCJT75A4KITLNR6GO/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2816 or the next vulnerability affects your stack