What’s Vulnerable › Vulnerabilities

CVE-2022-28169

Description

Brocade Webtools in Brocade Fabric OS versions before Brocade Fabric OS versions v9.1.1, v9.0.1e, and v8.2.3c could allow a low privilege webtools, user, to gain elevated admin rights, or privileges, beyond what is intended or entitled for that user. By exploiting this vulnerability, a user whose role is not an admin can create a new user with an admin role using the operator session id. The issue was replicated after intercepting the admin, and operator authorization headers sent unencrypted and editing a user addition request to use the operator's authorization header.

Affected products

How to fix

Upgrade to a fixed version: Brocade Fabric OS 8.2.3c, 9.0.1e, 9.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-28169 or the next vulnerability affects your stack