What’s Vulnerable › Vulnerabilities
CVE-2022-2817: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-15 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0213.
Affected products
- Fedoraproject Fedora: 35
- vim/vim: before 9.0.0213 — fixed in 9.0.0213
How to fix
Upgrade to a fixed version: vim/vim 9.0.0213. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/249e1b903a9c0460d618f6dcc59aeb8c03b24b20
- https://huntr.dev/bounties/a7b7d242-3d88-4bde-a681-6c986aff886f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CHFAR6OY6G77M6GXCJT75A4KITLNR6GO/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/249e1b903a9c0460d618f6dcc59aeb8c03b24b20
- https://huntr.dev/bounties/a7b7d242-3d88-4bde-a681-6c986aff886f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CHFAR6OY6G77M6GXCJT75A4KITLNR6GO/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2817 or the next vulnerability affects your stack