What’s Vulnerable › Vulnerabilities
CVE-2022-2818: Improper Removal of Sensitive Information Before Storage or Transfer in cockpit-hq/cockpit
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-15 · updated 2026-06-17
- Weakness: CWE-212
Description
Improper Removal of Sensitive Information Before Storage or Transfer in GitHub repository cockpit-hq/cockpit prior to 2.2.2.
Affected products
- cockpit-hq/cockpit: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: cockpit-hq/cockpit 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/cockpit-hq/cockpit/commit/4bee1b903ee20818f4a8ecb9d974b9536cc54cb4
- https://huntr.dev/bounties/ee27e5df-516b-4cf4-9f28-346d907b5491
- https://github.com/cockpit-hq/cockpit/commit/4bee1b903ee20818f4a8ecb9d974b9536cc54cb4
- https://huntr.dev/bounties/ee27e5df-516b-4cf4-9f28-346d907b5491
Get alerted when CVE-2022-2818 or the next vulnerability affects your stack