What’s Vulnerable › Vulnerabilities
CVE-2022-28201
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-674
Description
An issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. Users with the editinterface permission can trigger infinite recursion, because a bare local interwiki is mishandled for the mainpage message.
Affected products
- Debian Linux: 10.0, 11.0
- Wikimedia Foundation MediaWiki: before 1.35.6; from 1.36.0 before 1.36.4; from 1.37.0 before 1.37.2 — fixed in 1.35.6, 1.36.4, 1.37.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.6, 1.36.4, 1.37.2. Check the vendor advisory for mitigations.
References
- https://blog.legoktm.com/2022/07/03/a-belated-writeup-of-cve-2022-28201-in-mediawiki.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00027.html
- https://phabricator.wikimedia.org/T297571
- https://www.debian.org/security/2022/dsa-5246
- https://blog.legoktm.com/2022/07/03/a-belated-writeup-of-cve-2022-28201-in-mediawiki.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00027.html
- https://phabricator.wikimedia.org/T297571
- https://www.debian.org/security/2022/dsa-5246
Get alerted when CVE-2022-28201 or the next vulnerability affects your stack