What’s Vulnerable › Vulnerabilities
CVE-2022-28202
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-30 · updated 2026-06-17
- Weakness: CWE-79
Description
An XSS issue was discovered in MediaWiki before 1.35.6, 1.36.x before 1.36.4, and 1.37.x before 1.37.2. The widthheight, widthheightpage, and nbytes properties of messages are not escaped when used in galleries or Special:RevisionDelete.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 36
- Wikimedia Foundation MediaWiki: before 1.35.6; from 1.36.0 before 1.36.4; from 1.37.0 before 1.37.2 — fixed in 1.35.6, 1.36.4, 1.37.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.6, 1.36.4, 1.37.2. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2022/09/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PT4CHJKOQOVMI65TSNZRNV6FIWU7SGZD/
- https://phabricator.wikimedia.org/T297543
- https://security.gentoo.org/glsa/202305-24
- https://www.debian.org/security/2022/dsa-5246
- https://lists.debian.org/debian-lts-announce/2022/09/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PT4CHJKOQOVMI65TSNZRNV6FIWU7SGZD/
- https://phabricator.wikimedia.org/T297543
- https://security.gentoo.org/glsa/202305-24
- https://www.debian.org/security/2022/dsa-5246
Get alerted when CVE-2022-28202 or the next vulnerability affects your stack