What’s Vulnerable › Vulnerabilities
CVE-2022-2823: Slider, Gallery, and Carousel by MetaSlider < 3.27.9 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Slider, Gallery, and Carousel by MetaSlider WordPress plugin before 3.27.9 does not sanitise and escape some of its Gallery Image parameters, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- metaslider Slider, Gallery, and Carousel by MetaSlider – Image Slider, Video Slider: before 3.27.9 — fixed in 3.27.9
How to fix
Upgrade to a fixed version: metaslider Slider, Gallery, and Carousel by MetaSlider – Image Slider, Video Slider 3.27.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c88c85b3-2830-4354-99fd-af6bce6bb4ef
- https://wpscan.com/vulnerability/c88c85b3-2830-4354-99fd-af6bce6bb4ef
Get alerted when CVE-2022-2823 or the next vulnerability affects your stack