What’s Vulnerable › Vulnerabilities
CVE-2022-28281
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-787
Description
If a compromised content process sent an unexpected number of WebAuthN Extensions in a Register command to the parent process, an out of bounds write would have occurred leading to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 91.8, Firefox < 99, and Firefox ESR < 91.8.
Affected products
- Mozilla Firefox: before 99.0 — fixed in 99.0
- Mozilla Firefox ESR: before 91.8 — fixed in 91.8
- Mozilla Thunderbird: before 91.8 — fixed in 91.8
How to fix
Upgrade to a fixed version: Mozilla Firefox 99.0; Mozilla Firefox ESR 91.8; Mozilla Thunderbird 91.8. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1755621
- https://www.mozilla.org/security/advisories/mfsa2022-13/
- https://www.mozilla.org/security/advisories/mfsa2022-14/
- https://www.mozilla.org/security/advisories/mfsa2022-15/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1755621
- https://www.mozilla.org/security/advisories/mfsa2022-13/
- https://www.mozilla.org/security/advisories/mfsa2022-14/
- https://www.mozilla.org/security/advisories/mfsa2022-15/
Get alerted when CVE-2022-28281 or the next vulnerability affects your stack