What’s Vulnerable › Vulnerabilities
CVE-2022-28284
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-116
Description
SVG's <code><use></code> element could have been used to load unexpected content that could have executed script in certain circumstances. While the specification seems to allow this, other browsers do not, and web developers relied on this property for script security so gecko's implementation was aligned with theirs. This vulnerability affects Firefox < 99.
Affected products
- Mozilla Firefox: before 99.0 — fixed in 99.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 99.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1754522
- https://www.mozilla.org/security/advisories/mfsa2022-13/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1754522
- https://www.mozilla.org/security/advisories/mfsa2022-13/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1754522
Get alerted when CVE-2022-28284 or the next vulnerability affects your stack