What’s Vulnerable › Vulnerabilities
CVE-2022-28300
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-787
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Bentley MicroStation 10.16.02.034 CONNECT. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of JP2 images. Crafted data in a JP2 file can trigger a write past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-16202.
Affected products
- Bentley MicroStation: before 10.16.03 — fixed in 10.16.03
- Bentley View: before 10.16.03 — fixed in 10.16.03
How to fix
Upgrade to a fixed version: Bentley MicroStation 10.16.03; Bentley View 10.16.03. Check the vendor advisory for mitigations.
References
- https://www.bentley.com/en/common-vulnerability-exposure/be-2022-0007
- https://www.zerodayinitiative.com/advisories/ZDI-22-592/
- https://www.bentley.com/en/common-vulnerability-exposure/be-2022-0007
- https://www.zerodayinitiative.com/advisories/ZDI-22-592/
Get alerted when CVE-2022-28300 or the next vulnerability affects your stack