What’s Vulnerable › Vulnerabilities
CVE-2022-28320
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-457
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Bentley View 10.16.02.022. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of 3DM files. The issue results from the lack of proper initialization of memory prior to accessing it. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-16282.
Affected products
- Bentley MicroStation: before 10.16.03 — fixed in 10.16.03
- Bentley View: before 10.16.03 — fixed in 10.16.03
How to fix
Upgrade to a fixed version: Bentley MicroStation 10.16.03; Bentley View 10.16.03. Check the vendor advisory for mitigations.
References
- https://www.bentley.com/en/common-vulnerability-exposure/be-2022-0002
- https://www.zerodayinitiative.com/advisories/ZDI-22-597/
- https://www.bentley.com/en/common-vulnerability-exposure/be-2022-0002
- https://www.zerodayinitiative.com/advisories/ZDI-22-597/
Get alerted when CVE-2022-28320 or the next vulnerability affects your stack